Psychologists and kindergarten teachers like to tell us that we are all special. Well, when it comes to Microsoft online services, I am a bit too special. I have two accounts using the same email address; a Hotmail/Live account and an Office 365 account. I was using the Office 365 account for email (I own the domain name of the email account) and the Live account for Zune, Win7 phone syncing (SkyDrive) and PC folder syncing (Mesh). This used to work fine but is now broken. The problems started at about the same time that Microsoft announced the upgrade of Hotmail to Outlook.com. I am consistently getting redirected to the wrong logon server. So, to cut to the chase, I tried to change the email address associated with my Live account. The email-change page gave me the ominous warning that changing the email address would break syncing on my phone. This was not surprising. However, it went on to state that I would have to wipe and reset my phone back to its factory state to re-enable syncing using the new account name. Yikes! Whose idea of user-friendly is this? To be fair at least I got a warning.

So you might ask why would I be crazy enough to have to accounts with the same email address. Technology is an incremental thing; you try new stuff as it becomes available. I’ve owned my domain name for a long time. I wanted to have a constant in the shifting sands of the Internet. I created the Live account using that email address several years ago. I never actually used it for email though. My domain registrar also provided the POP email service for me. I then decided to make the switch to Office 365 for email and the other services it offers. I signed up with the same email address. I had to go to my domain registrar and update the MX records. Fortunately I understood the concepts around DNS records. Doing the Office 365 sign-up without knowing anything about DNS would be daunting. At any rate things worked fine for half a year until MS unveiled outlook.com as the successor to hotmail.com. The back end authentication code must have changed the cookie format so that both logins create similar cookies. Additionally there must be something that is stored on the back end though because even deleting cookies and starting in safe mode (so the Office sign-in assistant isn’t running) does not solve the problem.

The biggest issue is when I try to open a SharePoint Online document locally. The web service login prompts me for credentials and apparently goes to the wrong account so I get an access-denied. I also have to log into Office 365 on a different browser from SkyDrive (which is understandable; each browser has its own cookie cache). I can’t log into hotmail at all. No big loss since I didn’t get email there, but just part of the symptoms.

I will try limping along as things are until my phone contract expires. The chances of my getting another Windows phone are pretty slim. WP7 is a vast improvement over the prior Windows Mobile but it is far from perfect. Maybe it will be time to get an iPhone?

Advertisements